ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Help and Support > Mouse cursor jumps randomly to corners of the screen, win10 Goto page Previous  1, 2
Mouse cursor jumps randomly to corners of the screen, win10
  Author    Thread Reply to topic
infoseek2304



Joined: 13 Nov 2017
Posts: 4
 

Does opengl (no iltering) work?

 Reply with quote  
Post Sat Nov 25, 2017 4:43 pm 
 View user's profile Send private message
mictand



Joined: 14 Nov 2017
Posts: 5
 

I can also confirm that the Kirben build fixes the mouse cursor issue.

 Reply with quote  
Post Sat Nov 25, 2017 8:32 pm 
 View user's profile Send private message
harcalion



Joined: 29 Nov 2017
Posts: 1
 

Hello, nice people of this forum. This is my first post and of course it has to be a problem even if I have happily used ScummVM for many years. Thank you to everyone who has contributed.

Now the rant.

Using Kirben builds doesn't work for me. The behaviour is exactly the same whether I use ScummVM 1.8 (the build that comes with Kyrandia 3 from GOG) or any of the latest builds (Kirben or dailybot).

This is the INI file for the latest game, Kyrandia 3 - Malcolm's Revenge, displaying the issue (only custom option is the gfx_mode set to opengl_linear, no filtering):

code:

[scummvm]
last_fullscreen_mode_height=2880
speech_volume=192
native_mt32=false
midi_gain=100
last_fullscreen_mode_width=5120
talkspeed=60
gfx_mode=opengl_nearest
subtitles=false
multi_midi=false
fullscreen=true
themepath=E:\GOG Games\Legend of Kyrandia - Malcolms Revenge\ScummVM\
sfx_volume=192
music_volume=192
speech_mute=false
lastselectedgame=kyra3
music_driver=auto
aspect_ratio=true
versioninfo=1.9.0
autosave_period=300
enable_gs=false

[kyra3]
description=The Legend of Kyrandia: Malcolm's Revenge (DOS/English)
skip_support=true
savepath=E:\GOG Games\Legend of Kyrandia - Malcolms Revenge
path=E:\GOG Games\Legend of Kyrandia - Malcolms Revenge
helium_mode=false
gameid=kyra3
language=en
platform=pc
studio_audience=true
guioptions=sndNoMIDI vga gameOption1 gameOption2 gameOption3 lang_English




In windowed mode it works fine.
Additional info: it happens in computers with and without touchscreen or touchpad. It happens switching among several mice. I also place the start of the problem around the time when Windows 10 FCU was installed.

I will try to debug the problem if I manage to set up a ScummVM development environment.

EDIT: Launching the game from the ScummVM GUI makes the problem go away with any configuration that I have tested. It seems it is the GOG shortcut (scummvm -c path/to/ini.file game_name) which causes the issue for some reason. I have also realised that OpenGL nearest is no longer required for a non-filtered experience. Great!
 Reply with quote  
Post Wed Nov 29, 2017 2:03 pm 
 View user's profile Send private message
DX3M



Joined: 05 Nov 2017
Posts: 4
Solved with Kirden build 

I can also confirm the Kirden build fixed the mouse jumping issue, thanks for all the responses!

 Reply with quote  
Post Sun Dec 31, 2017 2:02 am 
 View user's profile Send private message
DjDiabolik



Joined: 02 Feb 2006
Posts: 44
 

mmmmmmmm... i have the same issue at today.......

I have try "Curse Of Monkey Island ITALIAN" on a windows 10 whit the latest daily build 64bit and the mouse jump around the screen randomly whitout any sense.

The Daily 32 bit download from main site not resolve the issue... how i can try ?

 Reply with quote  
Post Wed Jan 03, 2018 12:26 pm 
 View user's profile Send private message
DX3M



Joined: 05 Nov 2017
Posts: 4
 

quote:
Originally posted by DjDiabolik
mmmmmmmm... i have the same issue at today.......

I have try "Curse Of Monkey Island ITALIAN" on a windows 10 whit the latest daily build 64bit and the mouse jump around the screen randomly whitout any sense.

The Daily 32 bit download from main site not resolve the issue... how i can try ?


try this Kirben build, not the buildbot ones it worked for me Wink

quote:
Originally posted by rootfather
For everybody who is still having this issue or frequent crashes: Please try the Win32 builds provided by Kirben instead of the ones made by the buildbot.

You can find them at http://scummvm.org/downloads/scummvm-win32.exe

I could reproduce the issues with the buildbot dailys, but not with the Kirben builds. The thing is that the buildbot still uses SDL 1.2.15 which has a lot of issues with the current Windows version while the builds made by Kirben have SDL2. SDL1 is not maintained anymore and severly outdated, while SDL2 is the current version. (SDL is the library we use for video, sound and input handling on most of our supported platforms).

 Reply with quote  
Post Wed Jan 03, 2018 6:31 pm 
 View user's profile Send private message
DjDiabolik



Joined: 02 Feb 2006
Posts: 44
 

mmmmmmmmmmm... i have download this:
http://www.scummvm.org/downloads/scummvm-win32.exe

But it's at win32......... i prefer to use the w64 but there's no Kirben build.......

 Reply with quote  
Post Sun Jan 14, 2018 3:59 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page Previous  1, 2


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge