ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Help and Support > Mouse cursor jumps randomly to corners of the screen, win10 Goto page 1, 2  Next
Mouse cursor jumps randomly to corners of the screen, win10
  Author    Thread Reply to topic
DX3M



Joined: 05 Nov 2017
Posts: 2
Mouse cursor jumps randomly to corners of the screen, win10 

Didn't have issues before, but suddenly the mouse cursor jumps randomly to the corners of the screen, which is very annoying.

it occurs in every game and the launcher, windowed or fullscreen don't make a difference

using ctrl m doesn't make a difference

using version 1.9.0

please help, i've read about a few similar issues, but none have a solution

update: using mouse and keyboard, no touchscreen, and on desktop so no touchpad either. 25 views already it seems this is a popular issue?

 Reply with quote  
Post Sun Nov 05, 2017 11:21 pm 
 View user's profile Send private message
MacDaddyMeadows



Joined: 10 Nov 2017
Posts: 1
 

Same issue for me as well. Has worked flawlessly in the past, but now an issue.

Seems to affect me when the mouse is captured (ctrl+m).

Works fine when in windowed mode without the mouse being captured, but as soon as ScummVM captures the mouse, either in windowed or fullscreen mode the pointer will routinely jump around the screen erratically.

I've tried using another mouse in case it was a hardware incompatibility, but makes no difference.

 Reply with quote  
Post Sat Nov 11, 2017 5:40 pm 
 View user's profile Send private message
rootfather



Joined: 31 Mar 2015
Posts: 26
Location: Germany
 

Can you please try if this also happens in the current daily builds? You can download them via http://scummvm.org/downloads/#daily.

If it's still broken on the daily builds, please open a bug report with steps to reproduce and detailed information about your hardware, version of the OS and ScummVM build on http://bugs.scummvm.org.

Best regards
rootfather

 Reply with quote  
Post Sun Nov 12, 2017 4:30 pm 
 View user's profile Send private message Send e-mail Visit poster's website
infoseek2304



Joined: 13 Nov 2017
Posts: 4
Same Problem here 

Hi, I have got the same problem since the latest Windows 10 Updates.

 Reply with quote  
Post Tue Nov 14, 2017 8:59 am 
 View user's profile Send private message
mictand



Joined: 14 Nov 2017
Posts: 3
 

Same here.

I suspect it has something to do with the Windows 10 Fall Creators Update, where they changed the DPI settings.

I also had a similar problem with ScummVM in the past, but was able to get around it by disabling DPI scaling for ScummVM.
But after the Fall Creators Update, the same trick does not work.

 Reply with quote  
Post Tue Nov 14, 2017 6:49 pm 
 View user's profile Send private message
dopefish



Joined: 14 Nov 2017
Posts: 1
 

@rootfather: I had the same issue with version 1.9.0 (and 1.5), but it now works perfectly with the daily build version. thank you.

 Reply with quote  
Post Tue Nov 14, 2017 6:59 pm 
 View user's profile Send private message
infoseek2304



Joined: 13 Nov 2017
Posts: 4
 

Hi there,

it does work BUT ONLY with Graphics mode 2x. The setting OpenGL (No filtering), which causes the problem I think is not available anymore.

Asus GL502VSK
GTX 1070
I7

All drivers updated.

DPI scaling 125% (recommended setting Windows 10)

 Reply with quote  
Post Wed Nov 15, 2017 7:38 am 
 View user's profile Send private message
mictand



Joined: 14 Nov 2017
Posts: 3
 

No version or setting is working for me.

Mouse cursor jumps randomly no matter what I do.

 Reply with quote  
Post Wed Nov 15, 2017 8:02 pm 
 View user's profile Send private message
AE



Joined: 18 Nov 2017
Posts: 1
 

I can 100% confirm this is a Windows 10 Fall Creators Update issue. Everything was fine yesterday before the update - and broken this morning, when the update was applied. I just happened to be in the middle of a play-through of Indiana Jones and the Fate of Atlantis.

Anyone coming up with a solution?

 Reply with quote  
Post Sat Nov 18, 2017 1:40 pm 
 View user's profile Send private message
KainXVIII



Joined: 11 Feb 2008
Posts: 37
Location: Russia
 

quote:
Originally posted by AE
I can 100% confirm this is a Windows 10 Fall Creators Update issue. Everything was fine yesterday before the update - and broken this morning, when the update was applied. I just happened to be in the middle of a play-through of Indiana Jones and the Fate of Atlantis.

Anyone coming up with a solution?

Yep, same for me after W10 Fall Update.
I think setting renderer to OpenGL fixed the problem in latest SVN, BUT ScummVM now crashes very often. Maybe because same W10 Fall Update =(
PS - also i noticed that this problem not only in ScummVM but in some other games (like Broken Sword: Directo's Cut)..
 Reply with quote  
Post Sun Nov 19, 2017 11:07 am 
 View user's profile Send private message
DX3M



Joined: 05 Nov 2017
Posts: 2
 

So i tried the daily builds, but i'm not able to start any daily builds, i get an exception, disabled antivirus to check if this was the issue, but no luck

 Reply with quote  
Post Sun Nov 19, 2017 11:26 pm 
 View user's profile Send private message
KainXVIII



Joined: 11 Feb 2008
Posts: 37
Location: Russia
 

quote:
Originally posted by KainXVIII
quote:
Originally posted by AE
I can 100% confirm this is a Windows 10 Fall Creators Update issue. Everything was fine yesterday before the update - and broken this morning, when the update was applied. I just happened to be in the middle of a play-through of Indiana Jones and the Fate of Atlantis.

Anyone coming up with a solution?

Yep, same for me after W10 Fall Update.
I think setting renderer to OpenGL fixed the problem in latest SVN, BUT ScummVM now crashes very often. Maybe because same W10 Fall Update =(
PS - also i noticed that this problem not only in ScummVM but in some other games (like Broken Sword: Directo's Cut)..


Crashing in latest SVN fixed by making fresh install (or deleting all old dll's, my bad!)
 Reply with quote  
Post Thu Nov 23, 2017 9:35 am 
 View user's profile Send private message
infoseek2304



Joined: 13 Nov 2017
Posts: 4
 

Hi,

the Problem ist still there even with the latest Version.

 Reply with quote  
Post Fri Nov 24, 2017 10:48 am 
 View user's profile Send private message
rootfather



Joined: 31 Mar 2015
Posts: 26
Location: Germany
 

For everybody who is still having this issue or frequent crashes: Please try the Win32 builds provided by Kirben instead of the ones made by the buildbot.

You can find them at http://scummvm.org/downloads/scummvm-win32.exe

I could reproduce the issues with the buildbot dailys, but not with the Kirben builds. The thing is that the buildbot still uses SDL 1.2.15 which has a lot of issues with the current Windows version while the builds made by Kirben have SDL2. SDL1 is not maintained anymore and severly outdated, while SDL2 is the current version. (SDL is the library we use for video, sound and input handling on most of our supported platforms).

 Reply with quote  
Post Sat Nov 25, 2017 2:51 pm 
 View user's profile Send private message Send e-mail Visit poster's website
kintera



Joined: 18 May 2011
Posts: 2
Location: United States
Mouse jump issue 

I can confirm the Kirben build fixed the mouse jump issue on my system finally! I hope we can get the SDL2 fast tracked for the main & buildbot builds.

 Reply with quote  
Post Sat Nov 25, 2017 4:05 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page 1, 2  Next


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge