ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Help and Support > KQ 7 2.00b installed but not found by scummvm
KQ 7 2.00b installed but not found by scummvm
  Author    Thread Reply to topic
Kurutsu



Joined: 04 Nov 2005
Posts: 10
KQ 7 2.00b installed but not found by scummvm 

Hi, I have a copy of KQ7 version 1.51 which I updated to version 2.00b with the dosbox patch I found on the sierra website. It works okay when double clicking the icon but I want to run the game in scummvm. Unfortunately, it couldn't find any game in the folders.
I just played the dig the other day, so I know how scummvm works. Any idea what I am doing wrong?

Thanks for supporting all these good old classics so far!

 Reply with quote  
Post Tue Aug 08, 2017 6:40 am 
 View user's profile Send private message
tsoliman
ScummVM Developer


Joined: 19 Jan 2011
Posts: 350
Location: Waukesha, WI
 

Does the un-updated version work? (I mean re-copy the datafiles from your CDs)

 Reply with quote  
Post Tue Aug 08, 2017 1:25 pm 
 View user's profile Send private message Send e-mail
Kurutsu



Joined: 04 Nov 2005
Posts: 10
 

thanks for the quick reply!
No, that didn't work either.

 Reply with quote  
Post Tue Aug 08, 2017 3:23 pm 
 View user's profile Send private message
dreammaster
ScummVM Developer


Joined: 04 Nov 2005
Posts: 319
Location: Boston, Massachusetts, USA
 

Just to be sure.. are you using one of the latest daily builds of ScummVM, or one of the stable releases? Because the testing period for Kings Quest VII (amongst other later Sierra games) has only recently started

 Reply with quote  
Post Tue Aug 08, 2017 6:08 pm 
 View user's profile Send private message
Kurutsu



Joined: 04 Nov 2005
Posts: 10
 

I tried with the newest build, that seemed to have worked. Scummvm recognises both the 1.51 and the 2.00b version. Is there any difference between them? Which OS version do you recommend for the game ? Dos or windows?

I will start playing this game I finished Toonstruck

 Reply with quote  
Post Wed Aug 09, 2017 2:26 am 
 View user's profile Send private message
Kurutsu



Joined: 04 Nov 2005
Posts: 10
bugs? 

I was able to play the game but I encountered a few problems
1) I had to move the old avi files into the installed game folder because scummvm didn't find any.
2) After closing scummvm abruptly (I still had a saved bookmark so it was alright I thought) the saved bookmark is gone and scummvm can`t find the game folder anymore so probably I have to reinstall the game

 Reply with quote  
Post Sat Aug 12, 2017 2:46 am 
 View user's profile Send private message
Bakhtosh
Got a warning


Joined: 08 Oct 2006
Posts: 18
Re: bugs? 

quote:
Originally posted by Kurutsu
1) I had to move the old avi files into the installed game folder because scummvm didn't find any.

To me this sounds like you have installed the version 2.00b DosBox patch without altering options. In that case the RBT movies (used by the DOS version) are downloaded and the AVI movies (used by the Windows version) are not copied from the CD. You have to select the copy AVI movies option during the patch installation to have the AVI's copied.

quote:
Originally posted by Kurutsu
2) After closing scummvm abruptly (I still had a saved bookmark so it was alright I thought) the saved bookmark is gone and scummvm can`t find the game folder anymore so probably I have to reinstall the game

Are you sure that you didn't start the actual 1.9.0 stable build instead of the latest daily build after ScummVM closed abruptly?
Because it really sounds like it. There's no reason why the latest daily build first recognizes KQ7 version 1.51 from the CD and version 2.00b from the DosBox patch installation folder and then don't recognize them if you start it again.

But if you start the actual 1.9.0 stable build by accident it's clear that the KQ7 versions or the KQ7 savegames (bookmarks) aren't recognized. Since that's normal for that build as you noticed before when you tried the actual 1.9.0 stable build.
 Reply with quote  
Post Sat Aug 19, 2017 9:30 am 
 View user's profile Send private message
Kurutsu



Joined: 04 Nov 2005
Posts: 10
 

I downloaded the stable 1.9.1 version (july 17th), windows defender doesn't let me start the scummv ap of the master build.
I reinstalled kq7 2.00 but to no avail. Scummvm says there is no game in the folder. The debug windows says there is no resource.000 resource.map and errors in script 997 and 64918

 Reply with quote  
Post Sun Sep 10, 2017 6:25 am 
 View user's profile Send private message
criezy
ScummVM Developer


Joined: 23 Sep 2006
Posts: 456
Location: West Sussex, UK
 

The stable 1.9.1 version from our buidbot are only a minor iteration on the 1.9.0 version to fix bugs. It is there in case we found serious bugs in 1.9.0 and needed to do a bug fix release, but in the there was no need for it (so there is no official 1.9.1 release). The bottom line is that it doesn't support any new games compared to 1.9.0, and in particular doesn't support KQ7.

To play KQ7 your only choice currently is to use a recent master build.

 Reply with quote  
Post Sun Sep 10, 2017 10:36 am 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge