ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Android Port > ScummVM dev builds
ScummVM dev builds
  Author    Thread Reply to topic
cire_07



Joined: 12 Oct 2016
Posts: 1
ScummVM dev builds 

ScummVM black screen on all dev builds for android, waited hours nothing happens. Really just want to run riven. I have done it before.

also the buildbot does not show any past versions. There is probably some index of past versions but I can't find out how to get to them, it is not sign posted form the buildbot.

Phone: Alcatel onetouch c3

please help

 Reply with quote  
Post Thu Oct 13, 2016 8:17 am 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 829
 

http://buildbot.scummvm.org/

Top of Page... Click on the (all) after Snapshots.

 Reply with quote  
Post Fri Oct 14, 2016 6:53 am 
 View user's profile Send private message
mac_es



Joined: 31 Oct 2005
Posts: 99
 

I thought that was the unique with this issue... But I'm running my own compiled version...

In my case, the problem is in the AndroidManifest.xml as it register two activities with the MAIN filter.

This is my custom patch regarding this..

code:

Index: dists/android/AndroidManifest.xml
===================================================================
--- dists/android/AndroidManifest.xml
+++ dists/android/AndroidManifest.xml
@@ -28,14 +28,7 @@
             <category android:name="tv.ouya.intent.category.GAME"/>
          </intent-filter>
       </activity>
-      <activity android:name=".ScummVMActivity"
-            android:theme="@android:style/Theme.NoTitleBar.Fullscreen"
-            android:banner="@drawable/leanback_icon">
-        <intent-filter>
-            <action android:name="android.intent.action.MAIN"/>
-            <category android:name="android.intent.category.LEANBACK_LAUNCHER"/>
-        </intent-filter>
-      </activity>
+      
    </application>
 
    <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"/>



 Reply with quote  
Post Fri Oct 14, 2016 11:15 am 
 View user's profile Send private message
dafioram



Joined: 24 Sep 2016
Posts: 15
 

@ cire_07 I also experience the black screen for the dev builds. When using the stable versions 1.8.1 and the latest 1.9.0 I don't experience this black screen issue.

If digitall's fix works hopefully it can be applied to the dev builds, but why does it work for the releases, but not the dev builds?

 Reply with quote  
Post Wed Oct 19, 2016 5:21 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge