ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > PlayStation 2 Port > Problem with 1.7.0 Goto page Previous  1, 2
Problem with 1.7.0
  Author    Thread Reply to topic
Unique User Name



Joined: 30 Jan 2012
Posts: 23
Location: New England, USA
 

Hey Den...

Congrats on finally getting it started, glad I could help!

Without looking at my own setup I believe the only differences with running it on usb would be to change these in the ini file...


savepath=mass:
browser_lastpath=mass:
themepath=mass:
path=mass:


That should get it to run proper. If you are having slower speed problems or any other setup/config problems I would highly recommend "ScummVM 1.4.1 official release with the 14,033kb scummvm-N.elf". That is the setup I prefer myself as everything in that version seems to work flawlessly (with the exception of reloading a savegame before quitting to ensure it actually saves). As far as I can recall it worked 100% right out of the zip with no modifications and you can setup your configuration right from the frontend launcher. That version requires a memory card to run proper but atleast it will automatically save your settings when you run it if you have a memory card in the first slot. It will create a ScummVM folder with an icon.sys file, scummvm.icn file, and yes even create its own ScummVM.ini file. For me that is still the best version until a new one is released which fixes the savegame bug. Enjoy!


Last edited by Unique User Name on Sat Jan 16, 2016 11:47 pm; edited 1 time in total

 Reply with quote  
Post Sat Jan 02, 2016 7:55 pm 
 View user's profile Send private message
Den1982



Joined: 18 Nov 2015
Posts: 12
 

No, scummvm does not working from usbmass anyway.
Well, this is list for my bugs for ScummVM 1.7.0:
1. With SCUMMVM.ELF games don't starting. Only with SCUMMVM-S.ELF.
2. USB-keyboard don't working. In scummvm 1.3.1 working properly.
3. Games
- Freddi Fish 5 The Case of the Creature of Coral Cove (Windows/Russian) (ID: freddicove-win-ru);
- SPY Fox 3 Operation Ozone (English (US)) (ID: spyozon-us)
don't support, while support and working in ScummVM 1.7.0 for PC.
4. Savegame working but only on USBMASS. On HDD savegames deleted after quit.

 Reply with quote  
Post Sun Jan 03, 2016 11:15 am 
 View user's profile Send private message
Unique User Name



Joined: 30 Jan 2012
Posts: 23
Location: New England, USA
 

quote:
Originally posted by Den1982
No, scummvm does not working from usbmass anyway.
4. Savegame working but only on USBMASS. On HDD savegames deleted after quit.


Hello again Den...

You have me confused now...

In your list of bugs for ScummVM 1.7.0...
You say that savegame function IS working from usb,
BUT in your first sentence you say that it does NOT work at all from usb.
Hmmm...



To get your saves working from hard drive, read my post on the following link:

http://forums.scummvm.org/viewtopic.php?t=10518

I personally played Zak Mckracken 100% (from start to completion) using a hard drive on 1.7.0 during initial testing and still have the 8 saves I made in that version. To verify for you, after reading your post, I reinstalled and booted 1.7.0 on the ps2 hard drive and, the saves made from that version still load without issue. I was able to save again and the new save is still there after reboot. Saves you make with 1.7.0 are not backwards compatible with an older version however, for example, if you try a 1.7.0 save in a 1.4.1 setup it will produce an error on the save screen for those specific saves on their respective lines. Any intermixed saves from the correct version will load fine. Unless you need a newer version for a specific game I still recommend version 1.4.1 for the ps2 regardless of internal hard drive or usb configuration.



If I had the first post in this thread, I would edit in your bug list, along with any others that pop up in the future, so the Devs in charge would always have a clear list for all versions with only one place to look. Normally, I would make a new thread and start from scratch. If I have enough time when I'm done researching and typing this I will set something up.



The following is straight from -Max Lingua- out of one of the 1.7.0 readme documents...

If SCUMMVM.ELF hangs at start for you try disabling the adapter by setting in ScummVM.ini:

hdd_part=0
net_addr=0

I hope that helps!
 Reply with quote  
Post Mon Jan 04, 2016 12:29 am 
 View user's profile Send private message
Den1982



Joined: 18 Nov 2015
Posts: 12
 

quote:
Originally posted by Unique User Name

You say that savegame function IS working from usb,
BUT in your first sentence you say that it does NOT work at all from usb.
Hmmm...


Savegame working if set path of saves on usbmass(settings-->paths-->...). ScummVM starting from HDD of course.

quote:
Originally posted by Unique User Name

If SCUMMVM.ELF hangs at start for you try disabling the adapter by setting in ScummVM.ini:

hdd_part=0
net_addr=0

For me SCUMMVM.ELF is booting, but games not starting.
 Reply with quote  
Post Mon Jan 04, 2016 8:35 am 
 View user's profile Send private message
Unique User Name



Joined: 30 Jan 2012
Posts: 23
Location: New England, USA
 

I think I understand, you're saying that you are running an internal hdd setup while saving to a usb device? If so, and you're still trying to get your saves directly to a SAVES folder on your hard drive follow this:

While in-game: SAVE, then QUIT to scumm launcher menu.
While in-menu: LOAD, then reload the FILE you just saved.
After loading: QUIT, then on scumm launcher menu select QUIT.

That should stop your saves from disappearing. Shocked Very Happy

As to your other problem of your SCUMMVM.ELF loading properly but not playing your games... I need more info. Are you having this problem on your hdd setup, or usb, or both? Are you loading it from uLE, OPL, hddOSD, or other? I assume you're talking about 1.7.0 since you're in this thread but that is all I can deduce.

 Reply with quote  
Post Tue Jan 05, 2016 3:17 am 
 View user's profile Send private message
Den1982



Joined: 18 Nov 2015
Posts: 12
 

quote:
Originally posted by Unique User Name

As to your other problem of your SCUMMVM.ELF loading properly but not playing your games... I need more info. Are you having this problem on your hdd setup, or usb, or both? Are you loading it from uLE, OPL, hddOSD, or other? I assume you're talking about 1.7.0 since you're in this thread but that is all I can deduce.

I'm having this problem on hdd setup (i'm still could not start SVM 1.7.0 from USB). My version of ULE is 4.42d.
 Reply with quote  
Post Wed Jan 06, 2016 8:45 am 
 View user's profile Send private message
Unique User Name



Joined: 30 Jan 2012
Posts: 23
Location: New England, USA
 

Den ..

For your usb keyboard problems...

I haven't had the time to diagnose this yet, but it might have something to do with us not using more recent versions of uLE. There is a v4.42e_HDD version made on 10/27/2013 and the newest revision (06/02/2015) comes with Popstarter revision 13 WIP 05. You can even launch uLE from "__mbr" on that one. Also, if you're trying to load playstation 1 games from your hard drive, you can load your vcd images directly with that version. Here is the info:

POPStarter_r13_WIP_05
uLE_kHn_20150602

http://assemblergames.com/l/threads/ps2-pops-stuff.45347/page-61#post-813385



For your running scumm from USB problem...

Did you tinker with the following INI items that would affect hard drive and usb devices?

hdd_part = 0
net_addr = 0
usb_mass = 0

Off and on, 0 and 1, or setting paths for each of them, etc.



For your SCUMMVM.ELF problem...

As I understand you said the main launcher loads but your games won't start, it sounds like a simple path problem. Namely, plugins...

If you didn't set a plugin path it won't know what to do with your game image. For instance, if I wanted to play Zak Mckracken on 1.7.0 from the hard drive, these are the additions I would make to my INI file:

[scummvm]
pluginspath=pfs0:plugins/


[plugin_files]
zak=pfs0:plugins/scumm.plg


To get your settings made on the scummvm launcher to save (including game additions), as far as I know you have to use a memory card...

If you want to do this just remove the INI from your partition and add it to your ScummVM folder on memory card. Don't forget to have the icon.sys and scummvm.icn files just like previous versions had.

I never figured out why Scumm won't save your settings directly to the hard drive nor why you have to manually add files to a memory card (as it won't create them itself even if there is a memory card in slot 0). If anyone out there has a fix for this I would love to hear it. As I said before I still use 1.4.1 since everything I have works flawlessly on it, so I really haven't spent any amount of time on 1.7.0 since it first came out.

 Reply with quote  
Post Sun Jan 10, 2016 6:14 am 
 View user's profile Send private message
Specialist666



Joined: 23 Jan 2010
Posts: 4
Question: Crash 

Hello together,

sorry for disturbing your discussion.

I don't know if I'm a stranger here. I would like to know if my problem is the same you're talking about.

I downloaded the ScummVM v1.7.0 PS2-Package and created a PS2-DVD with some games on it.

The PS2-DVD is booting correctly, but after I choose a game in the menu, the screen is freezing.

Release 1.4.1 is working correctly.

Can I fix this manually by editing some files or is this a bug in the code?

I also tried it with PCSX2 1.2.1. The error message I get when I click on the "choose"-Button is:

(EE pc:001121EC) TLB Miss, addr=0x0 [load]

I hope, you can give me a hint. Smile

Thank you.

 Reply with quote  
Post Sun Jan 10, 2016 3:14 pm 
 View user's profile Send private message
Unique User Name



Joined: 30 Jan 2012
Posts: 23
Location: New England, USA
 

Hey Specialist ..

You're more than welcome to join our party, and I'll give you the best hints I can come up with.

I've never run an emulator IN an emulator before, and have no experience with the Ps2 emulator (so just a heads up that any info I give you in that context will be googled and not from experience), however, the error code you've listed seems to be a faulty image code.

Try this feature on your Ps2 emulator first...

"Boot CD/DVD (fast)"



If that doesn't help you could try burning your image again on a fresh disc, but It sounds like you're having the same problem as my friend Den here... Plugins.

If you are able to boot straight to the ScummVM launcher screen (frontend/backend/whatever you know it as), where you see your list of games, but when you try to load a game it freezes up... It is most likely an INI file configuration problem, where your paths aren't set up correctly. If you click the Options button, then Paths, on the launcher screen, it should display where your saves, themes, and plugins are being searched for. If no paths are set, you have to manually configure them in the ".ini" file that came with your zip.

Assuming your gamepaths are correct, I believe if you add the following under the [scummvm] section in your INI it should work:

pluginspath=cdfs:plugins/
themepath=cdfs:themes/
gui_theme=scummmodern

Sometimes, to get the MODERN theme working, you have to click the Options button, then the Right Arrow (next to Paths), then Misc, then Theme, then Modern, then Choose (it may hang for a few seconds), then OK.



You might have to add these as well under the playstation section, but I'm unsure:

hdd_part=0
net_addr=0
usb_mass=0

You might have to add your plugins maually to each game as well, but I'm unsure (example of Zak Mckracken):

[plugin_files]
zak=pfs0:plugins/scumm.plg

If your emulator has virtual memory card support, it would make your life easier to set it up to save to the INI file on the memory card "mc0:". If setup correctly it will read and write the INI that way. Then when you are done with all your settings and game additions, you could simply drop it where it goes in your image and it should work just like it did with the memory card (without the writing to file of course).


If none of the above helps you, please post your INI file contents and I will help you diagnose your problem further.


Last edited by Unique User Name on Wed Jan 13, 2016 10:43 pm; edited 2 times in total

 Reply with quote  
Post Sun Jan 10, 2016 10:10 pm 
 View user's profile Send private message
Specialist666



Joined: 23 Jan 2010
Posts: 4
Solution found! 

Hello again!

First of all: thanks a lot for your kind & really quick answer! Cool

You brought me back to the right way! Now, I got a solution for my problem.

Usually I don't use the emulator PCSX2. I'm indeed using a good old PlayStation2 to play these fantastic games. Smile

I used the emulator just for testing.

So you were right: while everything worked fine with ScummVM v1.4.1 (the offical one from the scummvm.org-website), the problem with v1.7.0 was, that I had to register the paths manually in the menu after the boot process. I had to set the path for the memory card, for the plugins and for the themes by myself. I had to set it ALL at once.

Otherwise (e.g. if I only set one of the three paths) the screen freezed by clicking on the "Choose"-Button.

Of course you can add the commands, more comfortable, permanent via ScummVM.ini. But it also worked by adding them manually, too.

I'm excited! Wink

So actually, my (working) PS2-ini-File looks like this:

---------------------------------------------
[scummvm]
versioninfo=1.7.0
tv_mode=ntsc
gfx_mode=3
pluginspath=cdfs:plugins/
themepath=cdfs:themes/
gui_theme=scummmodern
speech_volume=256
subtitles=false
fullscreen=true
autosave_period=900
sfx_volume=256
talkspeed=60
music_volume=256
aspect_ratio=true
hdd_part=0
net_addr=0
usb_mass=0
---------------------------------------------

So many thanks for your advice and have a good time!

 Reply with quote  
Post Mon Jan 11, 2016 12:32 pm 
 View user's profile Send private message
MrPunchy



Joined: 06 Nov 2006
Posts: 112
 

Someone can boot it from usb without a hd?

 Reply with quote  
Post Thu Jan 14, 2016 1:03 pm 
 View user's profile Send private message
Unique User Name



Joined: 30 Jan 2012
Posts: 23
Location: New England, USA
 

Hey Punchy ..

I'll add it to the issues list, since nobody seems to be able to run the elf from a usb device.

If anyone knows why it won't run on usb...
Please help Den and Mr.P.

 Reply with quote  
Post Sat Jan 16, 2016 11:26 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page Previous  1, 2


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge