ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > PocketPC/WinCE Port > Lands of Lore - memory error
Lands of Lore - memory error
  Author    Thread Reply to topic
Flieger Horst



Joined: 23 Nov 2011
Posts: 7
Lands of Lore - memory error 

I use ScummVM v1.4 on my HTC Touch ProII with windows mobile 6.5.

Games like Maniac Mansion, Monkey Island I+II, Sam & Max, Beneath a steel sky are working fine.

Now I wanted to try a rpg. Lands of Lore. I bought the PC-CD Version. The Auto-Scan finds the game. I see the logo of Virgin Interactive and Westwood Studios. Now the console opens with the following message.

ERROR: Cannot reallocate memory for VOC Data Block!

When I type "exit" to return to the game, Game and ScummVM closes.

Any help would be nice. But please type slowly, my english is not the best.

Thanks.

 Reply with quote  
Post Wed Nov 23, 2011 7:25 am 
 View user's profile Send private message
sev
ScummVM Lead


Joined: 21 Sep 2005
Posts: 1938
 

Most probably the file got copied wrong from the CD. Could you please try to copy it over again, and provide md5 checksum for it?


Eugene

 Reply with quote  
Post Wed Nov 23, 2011 8:26 am 
 View user's profile Send private message Visit poster's website
Flieger Horst



Joined: 23 Nov 2011
Posts: 7
 

Copying the file VOC.PAK again dont work. Same errormessage.

The checksum on the CD is:

C5B639B18295F3D91B270F6A02BEE9BF

 Reply with quote  
Post Wed Nov 23, 2011 10:53 am 
 View user's profile Send private message
eriktorbjorn
ScummVM Developer


Joined: 31 Oct 2005
Posts: 3289
 

Do the same files work if you run ScummVM on your computer instead? If the error happens regardless, I would agree that a damaged data file is a likely (but not certain) cause. But since support for this game is fairly new, perhaps some of the ScummVM ports have trouble with the game, or maybe a phone is simply more likely to really do run out of memory?

 Reply with quote  
Post Wed Nov 23, 2011 11:53 am 
 View user's profile Send private message
fuzzie
ScummVM Developer


Joined: 24 May 2010
Posts: 178
 

LordHoto improved the code to do VOC streaming (rather than preloading all the data) in all cases rather than just when using STREAM_AUDIO_FROM_DISK (seems DS-specific?) and committed that in early November, after 1.4.0 branched - so if it's really just running out of memory in the 1.4.0 version, a newer build from master might help?

 Reply with quote  
Post Wed Nov 23, 2011 12:19 pm 
 View user's profile Send private message
Flieger Horst



Joined: 23 Nov 2011
Posts: 7
 

> Do the same files work if you run ScummVM on your computer instead?

On the Win32 version of ScummVM the game works ... or more exactly ... I pass the intro and I can start a new game. I didnt try any further. Because I really want to play on my little smartphone toy :).


> ...so if it's really just running out of memory in the 1.4.0 version, a newer build from master might help?

I downloaded one of the daily builds.
filename: wince-master-latest.tar.bz2
foldername: wince-master-f5e945c7

I overwrote(?) the existing files on the memorycard of my phone and started ScummVM. I see the htc-equivalent of the windows hourglass. ScummVM didnt start. After 5 Minutes I stopped it. After that the phone needed a reboot, because the filemanager wont start any more.

If I understand it correct, this VOC file is just the sound. Would it help to just delete it or disable the sound somehow?

Thanks so far.

 Reply with quote  
Post Wed Nov 23, 2011 1:24 pm 
 View user's profile Send private message
Flieger Horst



Joined: 23 Nov 2011
Posts: 7
 

For a little moment I thought my problem is solved. I just deleted the VOC.PAK file. I used the last stable version of ScummVM. The intro passes normal and I can start a new game.

But ... after choosing a hero, the king tells me to enter the throneroom. Next I see is the console with the message that he misses the VOC files.

I tried a second time. This time the game crashes like at the beginning during the intro with the known memory error. I did not copy the VOC file again on the phone.

I deleted ScummVM and the gamedata and copied it again from hdd and CD on the phone. Restarted the phone. Again it crashes after the intro with the memory error. Again I deleted the VOC file. Again the games crashes during the intro with the memory error message from the beginning.

summary: Only once I managed it to pass the intro and choose a hero. This time another errormessage came up ("missing VOC file" or something like that). I could not rebuild this. All the other tries, the game crashes during the intro with the message "Cannot reallocate memory for VOC Data Block!"

Im confused now. I really hope you understand my poor english and you are not confused because of my description.

Maybe the logfiles will help you... I dont have the files from the nearly working try ... sorry


scummvm_stdout.txt (before deleting the VOC file):

Remote APIs client DLL attached
Remote APIs server DLL attached
User picked target 'lol-cd-2' (gameid 'lol')...
Looking for a plugin supporting this gameid... Kyra
Starting 'Lands of Lore: The Throne of Chaos'
Remote APIs client DLL detached
Remote APIs server DLL detached


scummvm_stderr.txt (before deleting the VOC file):

SDL: Version $Rev$ bootstrapping GAPI device
SDL: Device is portrait, OS version 5.2 build 21887
SDL: orientation 0
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Starting video access detection --->
SDL: System 480x800
SDL: Checking for GAPI
SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false
SDL: Trying Ozone
SDL: Running on Ozone
SDL: Ozone 480x800
SDL: <----- Detection finished. Running on Ozone driver at 480x800 (real 480, 800), using ARM accelerated blitter
SDL: Opening mode 640x480
SDL: Requested portrait mode
SDL: Setting landscape mode
WARNING: You are missing a valid 'translations.dat' file. GUI translation will not be available!
SDL: GAPI_WinPAINT NOT IMPLEMENTED
Cannot reallocate memory for VOC Data Block!
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: GAPI_WinPAINT NOT IMPLEMENTED
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: GAPI_WinPAINT NOT IMPLEMENTED
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation


scummvm_stdout.txt (after deleting the VOC file second time):

this file is empty


scummvm_stderr.txt (after deleting the VOC file second time):

SDL: Version $Rev$ bootstrapping GAPI device
SDL: Device is portrait, OS version 5.2 build 21887
SDL: orientation 0
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Starting video access detection --->
SDL: System 480x800
SDL: Checking for GAPI
SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false
SDL: Trying Ozone
SDL: Running on Ozone
SDL: Ozone 480x800
SDL: <----- Detection finished. Running on Ozone driver at 480x800 (real 480, 800), using ARM accelerated blitter
SDL: Opening mode 640x480
SDL: Requested portrait mode
SDL: Setting landscape mode
WARNING: You are missing a valid 'translations.dat' file. GUI translation will not be available!
SDL: GAPI_WinPAINT NOT IMPLEMENTED
Cannot reallocate memory for VOC Data Block!


Thanks for your help.

 Reply with quote  
Post Wed Nov 23, 2011 3:06 pm 
 View user's profile Send private message
LordHoto
ScummVM Developer


Joined: 30 Oct 2005
Posts: 1030
Location: Germany
 

quote:
Originally posted by Flieger Horst
For a little moment I thought my problem is solved. I just deleted the VOC.PAK file. I used the last stable version of ScummVM. The intro passes normal and I can start a new game.

But ... after choosing a hero, the king tells me to enter the throneroom. Next I see is the console with the message that he misses the VOC files.

I tried a second time. This time the game crashes like at the beginning during the intro with the known memory error. I did not copy the VOC file again on the phone.


The intro VOC files are in a INTROVOC.PAK file in the eng/, ger/, fre/ directories. So deleting VOC.PAK doesn't change much here.

For the game most talk files should be inside the "*.TLK" files.

At any rate deleting any voice files for the CD version might not work, as you already encountered. The problem seems to be that you don't have enough free memory. I am not sure but I thought the WinCE port uses split build files to prevent such issues nowadays.
 Reply with quote  
Post Wed Nov 23, 2011 3:33 pm 
 View user's profile Send private message
cerial
ScummVM Porter


Joined: 17 May 2009
Posts: 29
Location: Germany
 

Hi all!

I've just tested Lands of Lore (CD Version) (with the same md5 checksum for at least VOC.PAK) with ScummVM 1.4.0 (offical stable release) in the following configurations:

* HTC Touch Pro w/Windows Mobile 6.5 (640x480, 51MB program memory free)
* Asus MyPal A620 w/PocketPC 2003 (320x240, 33MB program memory free)
* Emulator w/Windows Mobile 6.1 (640x480, 49MB program memory free)
* Emulator w/Windows Mobile 6.5 (640x480, 42MB program memory free)

In all these cases, I've used the "big" single executable, as it's (normally) not needed anymore to use the split executables like scummvm1.exe etc. (I will explain this further down in this post).

Lands of Lore (CD Version, I've selected "german" in the game detection dialog), works perfectly here on all these configurations, I could enter the game and navigate in the dungeon in all cases. Sadly I don't have any other working physical devices, so I can't test this specific configuration (HTC Touch Pro II w/Windows Mobile 6.5)...

quote:
Originally posted by Flieger Horst
quote:
Originally posted by fuzzie
...so if it's really just running out of memory in the 1.4.0 version, a newer build from master might help?


I downloaded one of the daily builds.
filename: wince-master-latest.tar.bz2
foldername: wince-master-f5e945c7

I overwrote(?) the existing files on the memorycard of my phone and started ScummVM. I see the htc-equivalent of the windows hourglass. ScummVM didnt start. After 5 Minutes I stopped it. After that the phone needed a reboot, because the filemanager wont start any more.


Sadly, this is a known problem (at least for me) at this moment; generally it seems that the builds from master (and also all builds I built here locally for testing purposes) which include _all_ engines (!) have this problem. I tried to debug this problem with a remote debugger (gdb), but it seems the PE-loader of Windows CE doesn't succeed in the loading the executable at all, so I cannot use a debugger. I made like 30 test builds with engines successively enabled, and the outcome is that there seems to be a "magical barrier" related to the size of the scummvm.exe executable (not related to any specific engine, only to the size of the .exe-file). I never encountered this problem before - I'm developing for Windows CE since the year 2003 - but I have to confess that I never had an .exe-file of this size before. A possible solution would be to change the buildbot to produce a plugins-based build (this has one small drawback: scanning a large directory structure for games takes ages). But now the strangest thing: These "big" executables (18MB) work perfectly on my PocketPC 2003 testing device (with only 33MB memory free), on all emulators (WM5, WM6.1, WM6.5) - but, and that is really strange, not on physical WM5 & WM6.5 devices (at least) with much more free memory. I can't explain this behaviour, and I couldn't find anything in the internet about this problem - maybe it's a compiler error(?).

I'm sorry if this was too technical for you, but I wanted to let the other developers in this thread know about the exact details...

quote:
Originally posted by Flieger Horst
Maybe the logfiles will help you... I dont have the files from the nearly working try ... sorry

scummvm_stderr.txt (before deleting the VOC file):

SDL: Version $Rev$ bootstrapping GAPI device
...
SDL: Setting landscape mode
WARNING: You are missing a valid 'translations.dat' file. GUI translation will not be available!
...


This message seems to be really strange, it seems that the datafiles on your device are mixed up (different versions mixed). Could you please try the following to be _really_ sure you are using the right version of ScummVM (1.4.0) with all matching datafiles:
* (Re-)download the latest stable ScummVM release for Windows Mobile from here
* Extract these files to a newly created directory on your device (or extract them on your desktop and copy them to a new folder on your device)
* Start scummvm.exe (preferably, but you could also use scummvm2.exe) via a filemanager, not via a shortcut, to be sure that the right executable is used (don't forget to set the graphics mode to 2x on your 800x480 device before adding a game)
* Add the game (Lands of Lore) and try to start it again
If this still doesn't work, please check the logfile if the message above about translations.dat still appears (it really shouldn't), and please check (and report) your free program memory. I hope this fixes your problem.

quote:
Originally posted by LordHoto
At any rate deleting any voice files for the CD version might not work, as you already encountered. The problem seems to be that you don't have enough free memory. I am not sure but I thought the WinCE port uses split build files to prevent such issues nowadays.


In fact nowadays (since 1.4.0 to be exact) the split builds should be unneccesary. I've added a (not so well-known) workaround in commit "a97cd00 WINCE: Add workaround for memory management problem on Windows CE < 6.0" to finally get rid of all the memory problems we had so far on Windows CE < 6.0 (please note that I didn't write Windows Mobile, because even Windows Mobile 6.5 still uses Windows CE 5.2 "under the hood", so the abovementioned memory problem applies to all devices and configurations with PocketPC/Windows Mobile). I'm using this workaround since about 2004 without any visible side-effects in my other Windows Mobile projects like PocketUAE, so I really hope that it works as intended (all my tests so far were positive). I have planned to announce this in a new dedicated post here in the forums (to get feedback if the problem is really gone now and eventually get rid of the split builds) - but sadly hadn't enough time yet to do this - I hope I can do this on this weekend.

Ismail (CeRiAl)
 Reply with quote  
Post Thu Nov 24, 2011 1:07 am 
 View user's profile Send private message
Flieger Horst



Joined: 23 Nov 2011
Posts: 7
 

Here we go...

I deleted the whole folder with ScummVM and reinstalled the version you posted.

First start with scummvm.exe brings the same errormessage (VOC memory error) on the screen. Here are the logfiles.

scummvm_stdout.txt:

Remote APIs client DLL attached
Remote APIs server DLL attached
Das Spiel im Verzeichnis "\Speicherkarte\Programme\ScummVM\Spiele\Lore1\" scheint nicht bekannt zu sein.
Bitte geben Sie die folgenden Daten auf Englisch an das ScummVM-Team weiter sowie
den Namen des Spiels, das Sie hinzufügen wollten, als auch die Version/Sprache/usw.:
{"WESTWOOD.001", 0, "1330370ac5340cce09a0955dfac79821", 3226029},

Das Spiel im Verzeichnis "\Speicherkarte\Programme\ScummVM\Spiele\Lore1\DATA\ENG\" scheint nicht bekannt zu sein.
Bitte geben Sie die folgenden Daten auf Englisch an das ScummVM-Team weiter sowie
den Namen des Spiels, das Sie hinzufügen wollten, als auch die Version/Sprache/usw.:
{"INTROVOC.PAK", 0, "4cc346a4922f2448c8e58b108a3ee721", 6863477},
{"GENERAL.PAK", 0, "2dd5305434b11b40cbda565c0f729913", 1225285},

Das Spiel im Verzeichnis "\Speicherkarte\Programme\ScummVM\Spiele\Lore1\DATA\FRE\" scheint nicht bekannt zu sein.
Bitte geben Sie die folgenden Daten auf Englisch an das ScummVM-Team weiter sowie
den Namen des Spiels, das Sie hinzufügen wollten, als auch die Version/Sprache/usw.:
{"INTROVOC.PAK", 0, "4cc346a4922f2448c8e58b108a3ee721", 6863477},
{"GENERAL.PAK", 0, "2dd5305434b11b40cbda565c0f729913", 1225285},

Das Spiel im Verzeichnis "\Speicherkarte\Programme\ScummVM\Spiele\Lore1\DATA\GER\" scheint nicht bekannt zu sein.
Bitte geben Sie die folgenden Daten auf Englisch an das ScummVM-Team weiter sowie
den Namen des Spiels, das Sie hinzufügen wollten, als auch die Version/Sprache/usw.:
{"INTROVOC.PAK", 0, "4cc346a4922f2448c8e58b108a3ee721", 6863477},
{"GENERAL.PAK", 0, "2dd5305434b11b40cbda565c0f729913", 1225285},

User picked target 'lol-cd-1' (gameid 'lol')...
Looking for a plugin supporting this gameid... Kyra
Starting 'Lands of Lore: The Throne of Chaos'
Remote APIs client DLL detached
Remote APIs server DLL detached


scummvm_stderr.txt:

SDL: Version $Rev$ bootstrapping GAPI device
SDL: Device is portrait, OS version 5.2 build 21887
SDL: orientation 0
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Starting video access detection --->
SDL: System 480x800
SDL: Checking for GAPI
SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false
SDL: Trying Ozone
SDL: Running on Ozone
SDL: Ozone 480x800
SDL: <----- Detection finished. Running on Ozone driver at 480x800 (real 480, 800), using ARM accelerated blitter
SDL: Opening mode 640x480
SDL: Requested portrait mode
SDL: Setting landscape mode
SDL: GAPI_WinPAINT NOT IMPLEMENTED
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: GAPI_WinPAINT NOT IMPLEMENTED
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: GAPI_WinPAINT NOT IMPLEMENTED
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: GAPI_WinPAINT NOT IMPLEMENTED
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
Cannot reallocate memory for VOC Data Block!
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: GAPI_WinPAINT NOT IMPLEMENTED
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: GAPI_WinPAINT NOT IMPLEMENTED
SDL: Forced Portrait orientation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation
SDL: orientation 0
SDL: Selecting no translation


For second start I used scummvm1.exe. This brings up an new errormessage:

"Konnte keine Spiel-Engine finden, die dieses Spiel starten kann."
"Could not find a game engine to start this game."

Here are the log files.

scummvm_stdout.txt:

Remote APIs client DLL attached
Remote APIs server DLL attached
User picked target 'lol-cd-1' (gameid 'lol')...
Looking for a plugin supporting this gameid... failed
User picked target 'lol-cd-1' (gameid 'lol')...
Looking for a plugin supporting this gameid... failed
Remote APIs client DLL detached
Remote APIs server DLL detached


scummvm_stderr.txt:

SDL: Version $Rev$ bootstrapping GAPI device
SDL: Device is portrait, OS version 5.2 build 21887
SDL: orientation 0
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Starting video access detection --->
SDL: System 480x800
SDL: Checking for GAPI
SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false
SDL: Trying Ozone
SDL: Running on Ozone
SDL: Ozone 480x800
SDL: <----- Detection finished. Running on Ozone driver at 480x800 (real 480, 800), using ARM accelerated blitter
SDL: Opening mode 640x480
SDL: Requested portrait mode
SDL: Setting landscape mode
SDL: GAPI_WinPAINT NOT IMPLEMENTED
WARNING: lol is an invalid gameid. Use the --list-games option to list supported gameid!
WARNING: lol is an invalid gameid. Use the --list-games option to list supported gameid!


Next try with scummvm2.exe. Here I get the memory error again.

scummvm_stdout.txt:

Remote APIs client DLL attached
Remote APIs server DLL attached
User picked target 'lol-cd-1' (gameid 'lol')...
Looking for a plugin supporting this gameid... Kyra
Starting 'Lands of Lore: The Throne of Chaos'
Remote APIs client DLL detached
Remote APIs server DLL detached


scummvm_stderr.txt:

SDL: Version $Rev$ bootstrapping GAPI device
SDL: Device is portrait, OS version 5.2 build 21887
SDL: orientation 0
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Starting video access detection --->
SDL: System 480x800
SDL: Checking for GAPI
SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false
SDL: Trying Ozone
SDL: Running on Ozone
SDL: Ozone 480x800
SDL: <----- Detection finished. Running on Ozone driver at 480x800 (real 480, 800), using ARM accelerated blitter
SDL: Opening mode 640x480
SDL: Requested portrait mode
SDL: Setting landscape mode
SDL: GAPI_WinPAINT NOT IMPLEMENTED
Cannot reallocate memory for VOC Data Block!


Last try with scummvm3.exe. The same message like with scummvm1.exe.

scummvm_stdout.txt:

This file is empty.


scummvm_stderr.txt:

SDL: Version $Rev$ bootstrapping GAPI device
SDL: Device is portrait, OS version 5.2 build 21887
SDL: orientation 0
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Starting video access detection --->
SDL: System 480x800
SDL: Checking for GAPI
SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false
SDL: Trying Ozone
SDL: Running on Ozone
SDL: Ozone 480x800
SDL: <----- Detection finished. Running on Ozone driver at 480x800 (real 480, 800), using ARM accelerated blitter
SDL: Opening mode 640x480
SDL: Requested portrait mode
SDL: Setting landscape mode
SDL: GAPI_WinPAINT NOT IMPLEMENTED
WARNING: lol is an invalid gameid. Use the --list-games option to list supported gameid!


You wanted me to check the memory usage. Here I post in german to not post a wrong translation. Maybe you can translate for the others.

Datenspeicher gesamt: 218.7 MB
Belegter Speicher: 93.19 MB
Freier Speicher: 125.45 MB

Gesamter Programmspeicher: 187.35 MB
Benutzter Programmspeicher: 129.75 MB
Freier Programmspeicher: 57.60 MB

SD-Karte:
Gesamter Speicher: 7582 MB
Benutzter Speicher: 4422.66 MB
Freier Speicher: 3159.34 MB

Now some memory data from the hardware information:

RAM: 288 MB
Größe des Flashspeichers: 512 MB
Speichergröße: 218.7 MB

Thats all memory data I could extract from the phone.

Thanks so far.

 Reply with quote  
Post Thu Nov 24, 2011 3:46 pm 
 View user's profile Send private message
Flieger Horst



Joined: 23 Nov 2011
Posts: 7
 

No more ideas?

Thanks for the tries.

 Reply with quote  
Post Tue Nov 29, 2011 8:18 am 
 View user's profile Send private message
cerial
ScummVM Porter


Joined: 17 May 2009
Posts: 29
Location: Germany
 

Sorry for the late answer, I really didn't had any free time the last few days...

quote:
Originally posted by Flieger Horst
Here we go...

I deleted the whole folder with ScummVM and reinstalled the version you posted.

First start with scummvm.exe brings the same errormessage (VOC memory error) on the screen. Here are the logfiles.

scummvm_stdout.txt:

...
Das Spiel im Verzeichnis "\Speicherkarte\Programme\ScummVM\Spiele\Lore1\" scheint nicht bekannt zu sein.
Bitte geben Sie die folgenden Daten auf Englisch an das ScummVM-Team weiter sowie
den Namen des Spiels, das Sie hinzufügen wollten, als auch die Version/Sprache/usw.:
{"WESTWOOD.001", 0, "1330370ac5340cce09a0955dfac79821", 3226029},

Das Spiel im Verzeichnis "\Speicherkarte\Programme\ScummVM\Spiele\Lore1\DATA\ENG\" scheint nicht bekannt zu sein.
Bitte geben Sie die folgenden Daten auf Englisch an das ScummVM-Team weiter sowie
den Namen des Spiels, das Sie hinzufügen wollten, als auch die Version/Sprache/usw.:
{"INTROVOC.PAK", 0, "4cc346a4922f2448c8e58b108a3ee721", 6863477},
{"GENERAL.PAK", 0, "2dd5305434b11b40cbda565c0f729913", 1225285},

Das Spiel im Verzeichnis "\Speicherkarte\Programme\ScummVM\Spiele\Lore1\DATA\FRE\" scheint nicht bekannt zu sein.
Bitte geben Sie die folgenden Daten auf Englisch an das ScummVM-Team weiter sowie
den Namen des Spiels, das Sie hinzufügen wollten, als auch die Version/Sprache/usw.:
{"INTROVOC.PAK", 0, "4cc346a4922f2448c8e58b108a3ee721", 6863477},
{"GENERAL.PAK", 0, "2dd5305434b11b40cbda565c0f729913", 1225285},

Das Spiel im Verzeichnis "\Speicherkarte\Programme\ScummVM\Spiele\Lore1\DATA\GER\" scheint nicht bekannt zu sein.
Bitte geben Sie die folgenden Daten auf Englisch an das ScummVM-Team weiter sowie
den Namen des Spiels, das Sie hinzufügen wollten, als auch die Version/Sprache/usw.:
{"INTROVOC.PAK", 0, "4cc346a4922f2448c8e58b108a3ee721", 6863477},
{"GENERAL.PAK", 0, "2dd5305434b11b40cbda565c0f729913", 1225285},
...



Generally, this looks good, there's only one thing which could trigger the message: you seem to use an "unknown" version of LoL... This is why the engine prints out the checksums for these files. Maybe it has something to do with this special version of LoL, which needs more memory (but I really don't know why it should)..

quote:
Originally posted by Flieger Horst
For second start I used scummvm1.exe. This brings up an new errormessage:

"Konnte keine Spiel-Engine finden, die dieses Spiel starten kann."
"Could not find a game engine to start this game."

Here are the log files.

scummvm_stdout.txt:
...


That's perfectly ok, because scummvm1.exe doesn't support LoL at all (as you have seen Wink )

quote:
Originally posted by Flieger Horst
Next try with scummvm2.exe. Here I get the memory error again.
...


Seems to be the same problem here as in the first case

quote:
Originally posted by Flieger Horst
Last try with scummvm3.exe. The same message like with scummvm1.exe.
...


The same as for scummvm1.exe - this version doesn't support LoL at all.

quote:
Originally posted by Flieger Horst
You wanted me to check the memory usage. Here I post in german to not post a wrong translation. Maybe you can translate for the others.

Datenspeicher gesamt: 218.7 MB
Belegter Speicher: 93.19 MB
Freier Speicher: 125.45 MB

Gesamter Programmspeicher: 187.35 MB
Benutzter Programmspeicher: 129.75 MB
Freier Programmspeicher: 57.60 MB

SD-Karte:
Gesamter Speicher: 7582 MB
Benutzter Speicher: 4422.66 MB
Freier Speicher: 3159.34 MB

Now some memory data from the hardware information:

RAM: 288 MB
Größe des Flashspeichers: 512 MB
Speichergröße: 218.7 MB

Thats all memory data I could extract from the phone.

Thanks so far.


That also looks very good, you even have more free memory than I have on all my testing devices (not the emulators).
So, I have to say I'm sorry, I really don't know what the problem might be here - but I suppose it has something to do with this special version of LoL (it isn't recognized correctly by scummvm as you may have seen in the messages above.
I just have one final idea, I still could be related to your bigger resolution (480x800) as all my testing devices and emulators I've used have 240x320 and 480x640 screen sizes - I'll try an emulator with exactly your resolution this night, maybe I can reproduce the problem then.
But nevertheless, you should submit the "unknown" checksum to the game engine maintainer, so that he could add the correct checksums for this special version (if the game isn't modified in any way).

Thanks for your very detailed report, I'm very sorry that I couldn't help you (yet) with your problem...

Ismail (CeRiAl)
 Reply with quote  
Post Tue Nov 29, 2011 9:39 am 
 View user's profile Send private message
LordHoto
ScummVM Developer


Joined: 30 Oct 2005
Posts: 1030
Location: Germany
 

quote:
Originally posted by cerial
So, I have to say I'm sorry, I really don't know what the problem might be here - but I suppose it has something to do with this special version of LoL (it isn't recognized correctly by scummvm as you may have seen in the messages above.


It must be recognized correctly, otherwise ScummVM would refuse to run Lands of Lore. The messages posted are just from other directories than the game data file root, which should be the data/ directory.
 Reply with quote  
Post Tue Nov 29, 2011 1:22 pm 
 View user's profile Send private message
Flieger Horst



Joined: 23 Nov 2011
Posts: 7
 

Thank you all for the help.

Lands of lore still dont work on my smartphone, but its only one game. The other games are working fine.

Thanks to the developers of this really nice piece of software.

If anyone has another idea to solve my problem, a pm would be nice. I wont look that often on this board. If not ... CU.

 Reply with quote  
Post Thu Dec 01, 2011 10:12 am 
 View user's profile Send private message
cerial
ScummVM Porter


Joined: 17 May 2009
Posts: 29
Location: Germany
 

quote:
Originally posted by LordHoto
quote:
Originally posted by cerial
So, I have to say I'm sorry, I really don't know what the problem might be here - but I suppose it has something to do with this special version of LoL (it isn't recognized correctly by scummvm as you may have seen in the messages above.


It must be recognized correctly, otherwise ScummVM would refuse to run Lands of Lore. The messages posted are just from other directories than the game data file root, which should be the data/ directory.


Ok, I think you're right! It seems I was just confused by the fact that none of my datafiles match to these md5 checksums posted.

quote:
Originally posted by Flieger Horst
Thank you all for the help.

Lands of lore still dont work on my smartphone, but its only one game. The other games are working fine.

Thanks to the developers of this really nice piece of software.

If anyone has another idea to solve my problem, a pm would be nice. I wont look that often on this board. If not ... CU.


I'm really sorry, but I still can't replicate the problem. I've now checked ScummVM on Windows Mobile 6.5 w/480x800 resolution and only 48MB of memory free (on the emulator) and still everything works perfectly here. Sad
 Reply with quote  
Post Sat Dec 03, 2011 10:41 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge