ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Nintendo DS Port > Version 0.9.1beta6 released for testing! Goto page Previous  1, 2, 3, 4
Version 0.9.1beta6 released for testing!
  Author    Thread Reply to topic
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
 

Yep, the Supercard SD and M3 SD/MiniSD/Lite drivers are flaky. If saving works, great. If it doesn't, use the SRAM save.

After contributions from users on another thread, I'm ordering an M3 lite, and there's a chance that maybe once I have it I can improve the M3 driver a little.

If you want to contribute towards a Supercard SD/lite, feel free. If you do donate, make sure to mention that it's for a Supercard SD/lite.

 Reply with quote  
Post Fri Nov 10, 2006 10:39 pm 
 View user's profile Send private message
thebawp



Joined: 31 May 2006
Posts: 19
 

Basically I've reverted back to 0.61 in order to save type a games, and am using the latest binary to play and save type c games. Works out fine. =D

 Reply with quote  
Post Fri Nov 10, 2006 10:55 pm 
 View user's profile Send private message
Shadow_Zero



Joined: 07 Oct 2006
Posts: 34
Location: Netherlands
 

quote:
Originally posted by Metal_Spirit
Shadow Zero... The M3 lite is different from the M3 mini... ScummVm works on Both, and I can ashure you of that.

Just delete and re-create the dat file, and then Press L at startup to redetect your m3.


So it's logical that the micro-sd card with scummvm you use for the Lite won't work? I don't know exactly what happens with the .dat file. It is created by the M3 Manager, but it also gets changes from the M3 then...?

In any case, I got a new micro-sd card, sandisk 1gb and now it seems to work perfectly.
So I DO wonder why it didn't with the Kingston 1gb mini-sd. Ah, all these mind-boggling questions Wink
 Reply with quote  
Post Sat Nov 11, 2006 11:06 pm 
 View user's profile Send private message
Spyder



Joined: 24 Sep 2006
Posts: 22
 

I went from mini -> lite just by copying the contents of my card. No need to use the M3 manager at all, and scummvm worked 100% on both.

Your problems sound like an issue with the M3, there is a page on the M3 wiki for which brands of card work best. Try upgrading the firmware, the M3 team might've already fixed it!

http://m3wiki.com/index.php?title=Media_Card


also grats on the cash agentq, hope you enjoy the M3 Lite - it's been good to me, and soooo much faster to load scummvm games than my M3 mini Very Happy

 Reply with quote  
Post Sun Nov 12, 2006 2:39 pm 
 View user's profile Send private message MSN Messenger
iso jussi



Joined: 12 Mar 2007
Posts: 49
Location: Helsinki, Finland
 

I were playing Sam & Max. All went fine, but then when I were golfing, trying to free Max from a glass box (or whatever), then the touch screen stopped to work (in-game, in menu it worked) . So, where you think is the problem?

 Reply with quote  
Post Mon Apr 09, 2007 11:17 am 
 View user's profile Send private message
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
 

I think you accidentally hit up on the D-pad to switch to hover mode. Hit left to switch back to left click mode.

 Reply with quote  
Post Mon Apr 09, 2007 12:40 pm 
 View user's profile Send private message
desiccantsilicagel



Joined: 20 Apr 2007
Posts: 5
 

I know I'm not bringing anything new to the table here, but I have intermittent problems saving DOTT(CD) and Monkey1(CD) too. The saves will work about 80% of the time with no problems at all. The corrupted save says 'BLOB error' for the DOTT game, and just a blank screen for the Monkey1 game.

My specs:
Supercard SD
'Sandisk' 2GB SD Card (fake but works great Very Happy )

I always save, walk into another room, and make a backup save. Doing that, this 'problem' isn't really one!

 Reply with quote  
Post Sun Apr 22, 2007 5:58 am 
 View user's profile Send private message
Typhin



Joined: 25 Apr 2007
Posts: 2
 

Just found this yesterday, been messing around a little bit. I didn't see any official posting regarding DS-X compatibility, though...

Using 0.9.1beta6 on a DS-X card (with the DLDI drivers patched in) on original-style DS with version 1 firmware. So far, the only game I've tested was Flight of the Amazon Queen (using ScummVM build B). So far, nothing but slight graphical glitches (a black line being drawn across the screen every so often). Saving and loading seems to work fine. Saved a few times with no problems, shut off the system entirely, started up again, and loaded a save with no problems. Not extensive testing, but some info's better than none, right?

I'll be testing ther games later, I just thought I'd post this here. ^_^

 Reply with quote  
Post Wed Apr 25, 2007 6:03 pm 
 View user's profile Send private message
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
 

This thread is for an obsolete version of ScummVM DS. ScummVM has worked on the DSX for quite some time. Ever since they decided to cave in to demand and write a DLDI driver, in fact.

 Reply with quote  
Post Wed Apr 25, 2007 8:00 pm 
 View user's profile Send private message
Typhin



Joined: 25 Apr 2007
Posts: 2
 

Oh, oops. I didn't see any newer versions anywhere, though.

 Reply with quote  
Post Thu Apr 26, 2007 3:10 am 
 View user's profile Send private message
Badablek



Joined: 28 Jan 2007
Posts: 60
 

http://forums.scummvm.org/viewtopic.php?t=3671

0.9.1a beta6 < 0.9.1a

Wink

 Reply with quote  
Post Thu Apr 26, 2007 6:10 pm 
 View user's profile Send private message
Shadow_Zero



Joined: 07 Oct 2006
Posts: 34
Location: Netherlands
 

quote:
Originally posted by Shadow_Zero
Hmmmz, it remains so odd...
I got it to work perfectly with Monkey Island 2 (and M3 boot mode). The next time I tried to boot scummvm it didn't find the flash card. Rebooted with L+R and cleared the SRAM and the game worked fine again. Next time I wanted to play again it didn't find the flash card again and I couldn't use the clear SRAM "trick".
I have the idea this problem arises when I have made a savegame in Monkey Island.
I'll try to test with a few reboots without making a savegame and if that keeps working, make a savegame again.

Is this an issue? Is there a solution/workaround?

Setup again: M3-Mini + Kingston 1gb mini-sd

Sorry to post in such an old topic, but I had to smirk a bit since Google brought me back here, after I was searching for ways to clear my sram Razz
I wanted to do some GBA gaming on my SP again (after yeeeaaars), but my M3 Perfect kept giving me these "Warning! NDS save game already exists on this card, but autosave cannot be found. Backup failed. Press A to continute" messages >_<
So I did the 'clear sram' trick from scummvm and that did the trick Razz

Although, afterwards, I'm wondering if I could just disable autodelete and reboot, but not sure on that.

Sorry for the off-topic!
Hope everyone is doing well!
 Reply with quote  
Post Mon Jul 18, 2011 10:25 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page Previous  1, 2, 3, 4


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge