ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Wii Port > Cursor disappears
Cursor disappears
  Author    Thread Reply to topic
HumongousE



Joined: 18 Jun 2010
Posts: 4
Cursor disappears 

Hello. I loaded ScummVM via the Homebrew Channel and everything works just fine until I start a game. After the game loads, the cursor disappears. I have only tried Humongous Entertainment games, so could it be possible that this is just a bug loading the game cursor or something? Thanks.

*edit* Yes I checked and the cursor DOES show up in games that are NOT Humongous Entertainment (i.e. Indiana Jones). I have a feeling that it's the cursor in the game files that aren't loading. Is this fixable? Most of my ScummVM compatible games are Humongous Entertainment.


Last edited by HumongousE on Fri Jun 25, 2010 4:22 pm; edited 1 time in total

 Reply with quote  
Post Fri Jun 25, 2010 3:56 am 
 View user's profile Send private message
Red_Breast



Joined: 30 Sep 2008
Posts: 785
Location: The Bar Of Gold, Upper Swandam Lane.
 

Have you tried the Humongous games with a desktop version of ScummVM to see if the same problem occurs?
By desktop I mean Windows, Mac or Linux.

 Reply with quote  
Post Fri Jun 25, 2010 9:05 am 
 View user's profile Send private message
HumongousE



Joined: 18 Jun 2010
Posts: 4
 

It works just fine on Windows and on my Symbian phone.

 Reply with quote  
Post Fri Jun 25, 2010 4:21 pm 
 View user's profile Send private message
Red_Breast



Joined: 30 Sep 2008
Posts: 785
Location: The Bar Of Gold, Upper Swandam Lane.
 

Could you report it on the bug tracker. There's more chance that dhewg (ScummVM for Wii porter) will see it there.
You will need to make an account first. Try to put 'Wii' in the title and link or mention this thread. There's a link to the tracker on the home page of this web site along the right hand side.

 Reply with quote  
Post Sat Jun 26, 2010 8:45 am 
 View user's profile Send private message
HumongousE



Joined: 18 Jun 2010
Posts: 4
 

Will do. Although I won't be able to do it right now, I will do it as soon as I can. Thanks again.

 Reply with quote  
Post Fri Jul 02, 2010 12:32 am 
 View user's profile Send private message
dhewg
ScummVM Porter


Joined: 04 Jun 2008
Posts: 169
 

That sounds like it's a problem with 16bit cursors. I only have a few HE games, which ones are affected?

 Reply with quote  
Post Sat Aug 14, 2010 10:47 am 
 View user's profile Send private message
dramatico



Joined: 29 Sep 2010
Posts: 1
 

quote:
Originally posted by dhewg
That sounds like it's a problem with 16bit cursors. I only have a few HE games, which ones are affected?


I have some of the Blue's Clues games and I can say that the cursor is missing in-game. I tried today for example "Blue's ABC's Time (Windows)" and it happens. I also tried Blue's 123 with the same result.

On the Windows port the cursor is there. I believe in the Wii port for the HE Games the cursor is somewhere, but it the screen doesn't shows up where (if you go to the menu option, the red arrow is there).

As the first poster here, the cursor displays fine on other games like Monkey Island 2.

Regards,
 Reply with quote  
Post Wed Sep 29, 2010 6:09 pm 
 View user's profile Send private message
obcd



Joined: 09 Nov 2010
Posts: 19
Missing Cursor solution. 

I have done some research and posted my findings.

http://sourceforge.net/tracker/?group_id=37116&atid=418822

It should be just a matter of time now.
I am still testing the fix.

If someone wants the updated dol file for testing, just let me know. It's based upon the 1.2.0 stable release.

 Reply with quote  
Post Wed Dec 01, 2010 6:58 pm 
 View user's profile Send private message
Red_Breast



Joined: 30 Sep 2008
Posts: 785
Location: The Bar Of Gold, Upper Swandam Lane.
 

As this cursor problem only happens in some Humongous games would it be those only using a certain version of the SCUMM engine? I only have a few HE games. A couple of Spyfox and Pyjama Sam. Oh and Moonbase Commander! I've only played them on Desktop versions of ScummVM though.

 Reply with quote  
Post Wed Dec 01, 2010 8:07 pm 
 View user's profile Send private message
obcd



Joined: 09 Nov 2010
Posts: 19
 

It only happens in the wii port of scummvm.
I have some Freddi Fish and some PuttPutt games.
I still need to check which are infected by the problem. (And also check if they are cured.)

So far I can tell "Putt Putt travels trough Time" had the issue, and the patch solves it. All my games are in Dutch, so maybe the translation of their title back to English isn't fully correct. (Too lazy to look it up.)

 Reply with quote  
Post Wed Dec 01, 2010 8:50 pm 
 View user's profile Send private message
dhewg
ScummVM Porter


Joined: 04 Jun 2008
Posts: 169
 

took some time, but odcb found the issue. fix is part of the latest nightly build now.

 Reply with quote  
Post Wed Feb 16, 2011 7:41 pm 
 View user's profile Send private message
ktkallio



Joined: 20 Feb 2011
Posts: 1
 

quote:
Originally posted by dhewg
took some time, but odcb found the issue. fix is part of the latest nightly build now.


Sorry for my immense noobiness, but where can I find the latest nightly release? Is there a precompiled binary somewhere with this issue fixed?
 Reply with quote  
Post Sun Feb 20, 2011 12:26 pm 
 View user's profile Send private message
dhewg
ScummVM Porter


Joined: 04 Jun 2008
Posts: 169
 

get them here: http://buildbot.scummvm.org/builds.html

 Reply with quote  
Post Sun Feb 20, 2011 12:36 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge