ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > PlayStation 2 Port > Scummvm 1.0.0rc1 doesn`t work from USB. Please help!
Scummvm 1.0.0rc1 doesn`t work from USB. Please help!
  Author    Thread Reply to topic
acfgraz



Joined: 07 Oct 2008
Posts: 5
Scummvm 1.0.0rc1 doesn`t work from USB. Please help! 

Hi

I have a PS2 with Exploit on MC and an HDD inside.
I copied the new ScummVM-Version onto the USB-Stick and started the ELF on PS2.
It starts and i see the screen with the rotating 0 and 1.
Then after 1-2minutes it stops and goes into the PS2-Screen where you can choose the MCs or CD/DVD.
Tried the version 13.1 but same error.
With 12.0 it runs perfect!

Does anybody know, whats the problem?
Sorry for my English, i!am from Austria.

Thanks


Last edited by acfgraz on Tue Oct 06, 2009 10:26 am; edited 1 time in total

 Reply with quote  
Post Mon Sep 14, 2009 8:36 am 
 View user's profile Send private message
acfgraz



Joined: 07 Oct 2008
Posts: 5
 

Nobody else has the same problem?
ScummVM 1.0.0rc1 doesn`t work from USB-Stick. 13.1 same problem. 12.0 works fine.

Please help me.

 Reply with quote  
Post Tue Oct 06, 2009 10:25 am 
 View user's profile Send private message
phoenixclaws



Joined: 19 Aug 2009
Posts: 9
 

Been having this problem with the official 1.0 version as well.

The modified 0.12v3 version works very well.

1.0 just runs the loading 1&0s on the right handside for a while but nothing comes up.

I am using an older USB stick but I don't think that is the problem since it ran fine with 0.12 and the modified version.

I think I'll stick to the modified version for now.

 Reply with quote  
Post Wed Dec 02, 2009 6:16 pm 
 View user's profile Send private message
sunmax



Joined: 12 Jul 2009
Posts: 14
 

Hi there,

I'm sorry for the inconvenience that our PS2 release might have caused!

I'd assume the issue you are experiencing is related to the failure of detection of the (missing or misdetected) network adapter that jams ScummVM on start.

Could you please confirm which version of PlayStation2 do you have?

And (if it's a chubby one) whether you have the network adapter?

When you refer to version 0.12.0 that worked for you, is that the official release or the modded one?

The quickest solution in this case would be a version with the network bootstrap disabled (which I'll upload for you), still the golden goal is for the detection code to work on all PlayStation2 models Wink

And it already does on quite a few PS2 flavors and combos, I'm once again sorry that your ScummVM experience was less than satisfactory.

Looking forward to hearing from you soon.

Thanks!
-max

 Reply with quote  
Post Wed Feb 03, 2010 4:27 am 
 View user's profile Send private message
phoenixclaws



Joined: 19 Aug 2009
Posts: 9
 

Yes, I use an old phat PS2 SCPH-35001. I do have a network adapter but I do not have a HDD attached to it at the moment since I am working on replacing the IDE drive I was originally using.

PS2 ScummVM 1.0.0 freezes on loading the GUI with the spinning 0's and 1's.
As a result I have used the 0.12 hacked version and I have not observe any serious issues (besides the lingering old bugs) on my system. I was using the one with the disabled network adapter and using a USB flashdrive to read the games.

Thank you for any assistant you can provide Smile
The ScuumVM project is very impressive.

~Phoenixclaws~

 Reply with quote  
Post Wed Feb 03, 2010 5:11 am 
 View user's profile Send private message
sunmax



Joined: 12 Jul 2009
Posts: 14
 

Hi there Phoenixclaws!

>> Thank you for any assistant you can provide

Here it comes: faster than light.

I have to admit: I never tested a PS2 setup with network adapter, but no hdd!

Could you please try to remove the network adapter?

And see if it does make a difference when starting ScummVM?


>> The ScummVM project is very impressive.

Thanks, we are a great team, but I'm the black sheep, because I'm very creative to break the PlayStation2 port with slightly different and unpredictable patterns in every release Wink

Talk soon,
-max

 Reply with quote  
Post Wed Feb 03, 2010 5:22 am 
 View user's profile Send private message
phoenixclaws



Joined: 19 Aug 2009
Posts: 9
 

Heh, well i feel a little silly. I'm not sure why I never thought of removing the network adapter. But yep it works without it plugged in.

 Reply with quote  
Post Wed Feb 03, 2010 11:27 pm 
 View user's profile Send private message
sunmax



Joined: 12 Jul 2009
Posts: 14
 

Hey Phoenixclaws,

you are not silly at all, but a very responsive ScummVM user!

That's a flaw in the detection code, since the logic assumes:

"adpter: true" -> "hdd: true"

So it locks when trying to initialize the hdd...

Since most of the PS2 users bought an adapter to use a hdd, more than just the network. But your special case shows that we should handle this better.

I will take care of this for the next release (insert Pinocchio nose here).

Glad you can enjoy the great 1.0.0 release now Wink

Thanks,
-max

 Reply with quote  
Post Thu Feb 04, 2010 1:47 am 
 View user's profile Send private message
acfgraz



Joined: 07 Oct 2008
Posts: 5
 

But i have a network-adapter AND a HDD inside, and it doesnt work!

 Reply with quote  
Post Fri Mar 05, 2010 11:34 am 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge