ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Nintendo DS Port > Playing on NDSi
Playing on NDSi
  Author    Thread Reply to topic
QuinnTheEskimo



Joined: 04 Sep 2009
Posts: 1
Playing on NDSi 

Hello.

I recently purchased the R4 Upgrade Revolution for DS (NDSi/NDSL/NDS) card reader with the 2gb MicroSD card. I realise there are some instances of people having trouble porting to a DSi, and the legitimacy of the actual cards has been questioned. My problem is that I can't get Scummvm to work at all on my DSi; I've been using this guide; http://www.pocketgamer.co.uk/feature.asp?t=how_to&c=3252.
I've downloaded the correct software, patched the correct file, copied the files to the sdcard and when I try to run the reader a red box comes up on the top screen and in the screen it says '? Menu'.

Can someone help? :')

 Reply with quote  
Post Fri Sep 04, 2009 6:18 pm 
 View user's profile Send private message
Red_Breast



Joined: 30 Sep 2008
Posts: 785
Location: The Bar Of Gold, Upper Swandam Lane.
 

Whenever you use a guide for anything the first thing to do is check the date especially with software.
The guide is over 2 years old. It's using version 0.9 of ScummVM.
A second piece of advice. Let's say I had never heard of ScummVM and came across that guide. After reading the first few lines if I wanted to try it I'd go straight to Google and input 'ScummVM'. Then you're going to get a guide from the makers rather than a 3rd party.
Remember both bits of advice. They apply to all software.

Right. I don't have a DSi. I don't know if you're aware of it but you can use a DSi for homebrew but it's working in DS mode only. A similar example is before Wii homebrew was possible you could use a Wii but in Gamecube mode and use Gamecube homebrew.
Do you know what DLDI patching is? I only started using DS homebrew last year by which time you could buy DS flash cards which done the patching automatically. I've never DLDI patched anything as my CycloDS Evo does it for me.
So I would do some research first and find out if you're card does automatic DLDI patching. A quick Google suggests it does but make sure.

The guide in the next link is made by the person who ported ScummVM to the DS. It's also linked to in one of the stickies.
http://scummvm.drunkencoders.com/

The latest version of ScummVM for the DS and DSi can be downloaded from the downloads page. After 0.9 it went on to reach 0.13.1 earlier this year. Now the next release will be 1.0. However it hasn't been released yet but a RC (release candidate) has been released. So the latest is 1.0rc.
http://www.scummvm.org/downloads/

Good luck.

 Reply with quote  
Post Sat Sep 05, 2009 9:42 pm 
 View user's profile Send private message
KuroShiro



Joined: 15 May 2008
Posts: 452
Location: Miyazaki, Japan
 

Have you updated your DSi? R4s will not (and probably will never) work on the new firmware (version 1.4). If that is the case, buy an Acekard 2i from some place that will pre-install the firmware for you.

 Reply with quote  
Post Wed Sep 09, 2009 6:01 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge